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Budget Forecaster for Windows User Guide 
 

Budget Forecaster for Windows User Guide  

Budget Forecaster for Windows is a household budget and personal finance management software application 
developed by Strativia Software.   

Installation and system requirements 

System Support 

Microsoft Windows 2000/XP or higher 

Installation 

1. Insert the supplied installation CD into your PC and select the Setup file. 
2. Follow the instruction of the pop-up window. 
3. Accept the terms of the License Agreement to proceed. 
4. The installation program will download and run the Budget Forecaster Setup Wizard that will guide you 

through the steps of the installation process. 

Basic features 

Budget Forecaster is a personal finance product designed to help you maintain your household budget, control 
finances, analyze income and expenditure, and in general improve your financial planning. 

Basic Features 

The principal features of the program include: 

• Personal and family budgeting with comparisons 
• Income and expense tracking 
• Fully customizable categories 
• Transaction scheduling  
• Savings calculations 
• Mortgage analysis and printable amortization tables 
• Retirement analysis calculations 
• Insurance coverage calculations 
• Detailed monthly and annual printable reports 
• Colorful and illustrative graphics and charts 
• Data export  

Interface 

The Budget Forecaster interface consists of the following sections: 

• Menu bar 
• Toolbar 
• Workspace 
• Left Pane 
• Right Pane 

You can resize the left pane in the window. To do this, move the mouse pointer over the vertical or horizontal 
separators until the pointer changes to a double-headed arrow and the separator highlights blue. Then click and hold 
the left mouse button while dragging the pointer to a new position.  
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Menu bar 

The menu bar displays titles of drop-down menus that provide access to the program's primary functions. The drop-
down menus include: File, View, Budget, Graphs & Charts, Reports, Calculators, and Help. 

Toolbar 

The toolbar located under the menu bar contains icons that allow quick and easy access to the following frequently 
used commands: 

Current Budget, Current Income, Expense to Income Graph, Expense Distribution Pie Chart, and Net Worth Calculator 

Workspace  

The workspace is the central pane where household budget tables and action results are displayed.   

Left Pane  

The pane on the left of the workspace contains the following smaller areas: 

Entries Area | Budget Area | Tips  
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Entries Area  

The Entries area displays the Income and Expense folders by default when you use the program for the first time, and 
then it shows a hierarchical view of all income and expense categories that you have created in these folders. You can 
browse through and manage household budget entries within categories available in this area.  

Budget Area  

The Budget area enables you to select a period for the budget that you want to display in the workspace.  

Tips  

The Tips box displays useful hints for using Budget Forecaster. Click the rightwards and leftwards double arrows below 
the box to navigate between tips.   

Right Pane  

The pane on the right of the workspace contains a number of smaller areas: 

Changing background 

You can modify the appearance of Budget Forecaster by changing background colors for the menu, toolbar, workspace, 
side panes, and other elements.  

To change background colors, select Skins on the View menu, and then click the name of the skin you want to apply. 

Charts & Graphs 

You can quickly plot your household budget data in a bar graph or a pie chart by clicking Charts & Graphs on the main 
menu and selecting one of the available chart/graph types.  

• Expense to Income Ratio Graph provides income and expense comparisons on a monthly basis or over a year 
allowing you to assess planned and actual figures. 

• Expense to Actual Expense Ratio Graph provides planned and actual expense comparisons on a monthly basis 
or over a year allowing you to assess planned and actual figures. 

• Income Distribution Pie Chart shows actual and planned income by category. The color key shows the income 
categories, the color the category represents, and percentages for each category. 

• Expense Distribution Pie Chart shows actual and planned expenses by category. The color key shows the 
expense categories, the color the category represents, and percentages for each category.  

Chart/graph options 

Using the command buttons on the toolbar, you can specify various chart/graph options:  

• Build charts and graphs for the entire year or any month of the last, current, or next year by clicking the 
current date on the toolbar and selecting another date from the drop-down list. 

• Switch between a color and monochrome view.   
• Send a chart or graph to a printer. 

Changing budget names 

A household budget is named Family budget by default. You can replace the current name of your budget with any 
other variant.  

Change a budget name  
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1. Display the Budget Name box by doing one of the following: 

• On the Edit menu, select Budget Name. 
• In the Getting Started area, click Enter Budget Name. 

2. Modify the name of your budget. 
3. Click Apply.  

 To discard the changes you have made, click Cancel.  

Managing categories 

You can create, rename, or delete categories.  

Add a category  

1. Display the Categories box by doing one of the following: 

• On the Edit menu, select Categories. 
• In the Getting Started area, click Create Categories. 

2. In the Categories box, select the node where you want to create a new category. 
3. Click New on the toolbar. 
4. Type a name for the new category. 

 Rename a category  

1. On the Edit menu, select Categories. 
2. In the Categories box, do one of the following: 

• Single-click a category, click Rename on the toolbar and modify the name. 
• Double-click a category and modify its name.  

Delete a category  

1. On the Edit menu, select Categories. 
2. In the Categories box, select the category you want to remove. 
3. Click Delete on the toolbar and then click Yes in a confirmation dialog. 

Managing schedule transactions 

You can create, edit, or remove schedule transactions, i.e. recurring transactions that need to be paid on a regular 
basis. Such transactions can include utility bill payments, stock dividends, loan repayments, etc.  

Add a schedule transaction  

1. Display the Schedule Transactions box by doing one of the following: 

• On the Edit menu, select Schedule Transactions. 
• In the Getting Started area, click Schedule Transactions. 

2. Click New on the toolbar. 
3. Fill in the fields of a transaction adding form. 
4. Click Apply.  
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Edit a schedule transaction  

1. Display the Schedule Transactions box by doing one of the following: 

• On the Edit menu, select Schedule Transactions. 
• In the Getting Started area, click Schedule Transactions. 

2. Either highlight the transaction to modify and click Edit on the menu, or simply double-click the transaction. 
3. Make changes in the fields of a transaction editing form. 
4. Click Apply. 

Click Cancel to discard the changes you have made.  

Delete a schedule transaction  

1. Display the Schedule Transactions box by doing one of the following: 

• On the Edit menu, select Schedule Transactions. 
• In the Getting Started area, click Schedule Transactions. 

2. In the Categories box, select the transaction you want to remove. 
3. Click Delete on the toolbar and then confirm removal in the dialog box that appears. 

Creating a household budget 

To create a budget, follow the steps described below.  

Step 1. Name a budget  

A household budget is named Family budget by default. You can replace the current name of your budget with any 
other variant.  

1. On the Edit menu, select Budget Name to display a name changing box. 
2. Modify the name of your budget as necessary. 
3. Click Apply.  

Step 2. Select a budget period  

In the household Budget area, select a budget period. The selected period immediately displays in the workspace 
having a default zero value in the Planned, Actual, and Difference columns.  

Note. The Budget area displays the last, current, and next year. You can select the whole year by a single click, or any 
calendar month by clicking the plus sign next to the selected year to open a 12-month list and then single-clicking the 
month you need.  

Step 3. Create budget categories  

1. In the Getting Started area, click Create Categories to open the Categories box. 
2. Select either Income or Expense. 
3. Click New on the toolbar. 
4. Type a name for the new category. 

 Step 4. Create actual budget entries  
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1. In the Entries area, select a period within which you want to enter data. The Entries area displays the current 
date by default. To select another period, click the current date, and then select a year and a month from the 
list. 

2. Select a folder in the categories tree. 
3. Open the Entries box by doing one of the following: 

• In the Getting Started area, click the New Entry link. 
• In the Entries area, click the New Entry button. 

4. In the Entries box, select one of the existing household budget categories.  
5. In the Amount field, enter an amount value. 
6. In the Date field, enter a date for the budget entry. 
7. Click Apply. 

Note. As soon as you click Apply, the entry is added to the budget table, but the Entries box remains open allowing you 
to create another budget entry.  

Step 5. Create planned budget entries  

1. Open the Planned box by doing one of the following: 

• Double-click an entry in the budget table. 
• Single-click entry in the budget table and click the Enter Planned. 
• Right-click an entry and select Enter Planned on the shortcut menu. 

2. In the Planned box, select a budget category with a double-click. 

Note. If you selected a category in step 1, this step should be omitted, since the category is selected by default. 

4. Enter an amount value for the category. 
5. Click Apply. 

Note. As soon as you click Apply, the entry is added to the budget table, but the Planned box remains open allowing 
you to create another budget entry. 

Adding actual entries 

Add actual budget entries  

1. Open the Entries box by doing one of the following: 

• In the Getting Started area, click the New Entry link. 
• In the Entries area, click the New Entry button. 

2. In the Entries box, select one of the existing budget categories. 
3. In the Amount field, enter an amount value for the planned budget entry you want to create. 
4. In the Date field, enter a date for the budget entry. 
5. Click Apply. 

Note. As soon as you click Apply, the entry is added to the budget table, but the Entries box remains open 
allowing you to add household budget entry. 

Add planned budget entries  

1. In the Budget area, select a budget period. The corresponding budget table appears in the workspace. 
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2. Open the Planned box by doing one of the following: 

• Double-click an entry in the budget table. 
• Single-click entry in the budget table and click the Enter Planned. 
• Right-click an entry and select Enter Planned on the shortcut menu. 

3. In the Planned box, select a budget category with a double-click.  

Note. If you selected a category in step 2, this step should be omitted, since the category is displayed by default. 

4. Enter an amount value for the category. 
5. Click Apply. 

Note. As soon as you click Apply, the entry is added to the budget table, but the Planned box remains open allowing 
you to create another household budget entry. 

Viewing and editing household budget records 

Viewing a budget  

First select a period in the Budget area, select the last, current or next year or any calendar month within the period. A 
budget table opens in the workspace where you can see planned and actual income and expenses and difference 
between them. You can also view existing budget categories by clicking the plus sign in the appropriate entries.  

• If you select a year, the workspace displays a balance for the year and each calendar month from January 
through December.  

• If you select a month, the workspace displays a balance for the whole year and the month of your choice.  

Deleting categories and entries 

 Delete a category  

1. On the Edit menu of the main menu bar, select Categories. 
2. In the Categories box, select the category you want to remove. 
3. Click Delete on the toolbar and confirm removal when a dialog box appears.  

Delete a planned entry  

1. In the Budget area, select a budget period. The corresponding household budget table appears in the 
workspace. 

2. In the budget table, select an entry.  
3. Double-click the entry, to open the Planned box. 

Note. If you selected a category in step 2, this step should be omitted. 

4. Enter an amount value for the category. 
5. Click Apply.  

Delete an actual entry  

1. Select a category in the Entries area. The entry appears in the workspace. 
2. Click Delete on the toolbar. 
3. Click Yes in the confirmation dialog.  

Budget view options 
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You can use several household budget view options accessible from the Budget menu on the main menu bar.  

• Current Budget displays balances for the current year and the current month. 
• Last Year Budget displays balances for the last year and the same calendar month as the current one, one 

year back. 
• Next Year Budget displays balances for the next year and the same calendar month as the current one, one 

year forward.  

All three types of budget appear in the workspace as a table showing comparisons between actual and planned income 
and expenses. Values in tables are arranged in categories which you can view by clicking the plus sign in the 
appropriate entry.  

You can also choose to display only income or expenses for the current, last, or next year by selecting one of the 
options on the Budget menu.  

Generating reports 

Budget Forecaster generates reports on the basis of data you have entered in the Budget section to help you review 
and analyze your income, expenditure and household budget details. Any reports can be printed, exported, or sent by 
email.  

To generate a report, click Reports on the menu bar and select one of the report types from the list.  

All reports on income and expenses share the following common features:  

• Cover a 12-month period.  
• Compare planned and actual income/expenses for each month and the entire year showing their difference. 
• Display detailed information on income/expenses for each calendar month by categories. 
• Show total annual income/expenses. 
• Display three months at a time and allow navigating between pages with the navigation arrows on the 

toolbar.  

You can build a wide range of reports including:  

• Annual household Budget report contains budget details including after-tax income, difference between 
annual planned and actual expenses, total annual expenses by category, a total of all expense categories for 
the entire year, and total saving/deficit calculations. 

• Income report gives an account of your income on a monthly basis by category and provides your total 
annual income.  

• Expense report provides an overview of your expenses on a monthly basis by category and provides your 
total annual expenses.  

• Expense to Income Ratio report provides income/expense ratio by month and shows the relation of your total 
income to total expenses. 

• Expense to Total Expense Ratio displays comparisons between planned and actual expenses. 
• Scheduled Transactions report shows information on regular payments or money transfers arranged by name, 

category, period, amount, and next payment date. 

Customizing reports 

Customizing the view  

You can customize the view of your report by changing background colors, page layout, page settings, adding 
watermarks and images, and applying other settings. The menu and toolbar at the top of the Reports window contain 
commands that allow creating custom reports.  
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Customizing toolbar and menu commands  

You can modify and rearrange commands on the toolbar and menu.  

To start customizing, select Customize on the View menu. Once the Customization dialog box opens, right-click any 
command, and then select one of the commands on the shortcut menu. You can delete and reset commands, display 
both an icon and text for a command, or either of them separately, and move commands by dragging.  

Add a command  

1. On the View menu, click Customize. 
2. In the Customization dialog box, click the Commands tab. 
3. In the Commands box, click a command. 
4. Drag the command from the Commands box to where you want it to appear on the toolbar or menu, and 

then release the mouse. 

Net Worth 

The Net Worth calculator determines the amount left after you subtract liabilities from expenses.   

Calculate a net worth  

1. On the Calculators menu, click Net Worth. The Net Worth box appears that consists of two sections - Positive 
for assets and Negative for liabilities. 

2. In the Net Worth box, click Add Category under the Positive or Negative section respectively.  
3. In the Prompt box, type a name for the new category, and then click OK. 
4. Click Add Item to add subcategories for the category. 
5. Single-click a subcategory and enter a value for it. The balance for the category is automatically calculated 

and displayed next to the category name. 
6. In the Negative section, repeat steps 2-5 to calculate a negative balance. 
7. In the bottom line of the Net Worth box, see the total balance, which is automatically calculated. 

  

To remove any selected categories or subcategories, select the Delete button at the bottom of the box.  

Life Insurance Needs 

The Life Insurance Needs calculator enables you to specify an annual amount of life insurance coverage.  

Calculate income replacement  

1. On the Calculators menu, click Life Insurance Needs.  
2. Fill in the fields of the Life Insurance Needs box. 
3. Click Calculate. 

Savings Goal 

The Savings Goal calculator offers three calculation options allowing you to estimate:   

• the amount you need to contribute weekly/monthly/annually to meet your savings goal.  
• the amount you will have in savings at the end of the specified savings period by making specified savings 

contributions. 
• the date by which you can meet you savings goal.  
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To calculate any of the savings goals, you should first select Savings Goal on the Calculators which opens the Savings 
Goal box, and then do one of the following:  

Calculate a target amount  

1. In the Goal Name text field, enter the name of your savings goal. 
2. Select the Target Amount radio button in the right pane. 
3. In the Saving Amount field, enter the amount to save at regular intervals. 
4. In the Periodicity field, choose if you want to save every week, month, or year. 
5. In the Target Date field, set the date by which the target amount should be saved. 
6. Click Calculate.  

Calculate a saving amount  

1. In the Goal Name text field, enter the name of your savings goal. 
2. Select the Saving Amount radio button in the right pane. 
3. In the Target Amount field, enter the amount you want to save. 
4. In the Periodicity field, choose if you want to save every week, month, or year. 
5. In the Target Date field, set the date by which the target amount should be saved. 
6. Click Calculate.  

Calculate a target date  

1. In the Goal Name text field, enter the name of your savings goal. 
2. Select the Target Date radio button in the right pane. 
3. In the Target Amount field, enter the amount you want to save. 
4. In the Saving Amount field, enter the amount to save at regular intervals. 
5. In the Periodicity field, choose if you want to save every week, month, or year. 
6. Click Calculate. 

Mortgage Payment 

The Mortgage Payment calculator determines monthly payments you should make to cover the interest and the 
outstanding amount till the end of the mortgage period.  

Calculate mortgage payments  

1. On the Calculators menu, click Mortgage Payment to display the Mortgage Payment box. 
2. In the Principal field, enter the total amount you have borrowed. 
3. In the Down Payment field, enter the amount paid in advance. 
4. In the Interest Rate field, provide an interest rate on the mortgage loan. 
5. In the Years field, type the number of years you need to repay the mortgage loan. 
6. In the Annual Taxes field, provide the amount you pay annually in taxes. 
7. Click Calculate. 

To access an amortization spreadsheet, select the Amortization Table button at the bottom of the box. An amortization 
table is a spreadsheet that shows each loan payment broken down into interest and principal payments, total interest 
and principal paid to date, and the remaining principal balance on each payment date. 

Financial Ratios 

The Financial Ratios calculator defines three types of ratios that can be regarded as objective assessments of your 
financial status.  

• Basic liquidity ratio shows the number of months for which you can pay your current monthly expenses using 
your monetary assets.  

• Debt payment to income ratio shows if your after-tax income is adequate to make debt repayments. 
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• Debt to asset ratio shows if your indebtedness is greater than available assets.  

Calculate basic liquidity ratio  

1. On the Calculators menu, click Financial Ratios. 
2. In the Financial Ratios box, click the Basic Liquidity tab. 
3. In the Liquid Assets field, enter cash assets or assets that are easily convertible into cash. 
4. In the Monthly Expenses field, enter the amount of your monthly expenditure. 
5. Click Calculate.  

Calculate debt payment to income ratio  

1. On the Calculators menu, click Financial Ratios. 
2. In the Financial Ratios box, click the Debt Payment to Income tab. 
3. In the Annual Debt Payment field, enter a monthly debt payment multiplied by 12. 
4. In the After-Tax Income field, enter the being that which remains after payment, especially of income taxes. 
5. Click Calculate.   

Calculate debt to asset ratio  

1. On the Calculators menu, click Financial Ratios. 
2. In the Financial Ratios box, click the Debt to Asset tab. 
3. In the Total Liabilities field, enter the total amount. 
4. In the Total Assets field, enter the amount. 
5. Click Calculate.  

Note. Each field has a tooltip which contains supplementary information and can help you enter the required 
data. Tooltips appear when you hover the mouse pointer over the selected field.   

Retirement Needs 

The Retirement Needs calculator determines a future amount needed to cover your estimated retirement needs.   

Calculate retirement needs  

1. On the Calculators menu, click Retirement Needs. 
2. Fill in the fields of the Retirement Needs box. 

Note. Each field has a tooltip which contains supplementary information and can help you enter the required data. 
Tooltips appear when you hover the mouse pointer over the selected field.   
 
       3.    Click Calculate. 

 If you need additional help with your Budget Forecaster for Windows software application, feel free to call our 
Customer Support Helpdesk.   
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